PSA - AW Zone (ww5) - Service unavailable or long loading time
Incident Report for Datto
Postmortem

The Autotask AW zone (about 10% of Autotask partners) experienced some periods of high latency and a brief service interruption lasting less than 5 minutes during the morning of Wednesday June 23.

Our research revealed that the cause was due to a defect in the 2021.1 release which had been deployed the night before. This release included a new user experience for the Company/Account pages.

One of the features of this new UIX was the ability to view the number of active contacts for a company. An inefficient method was used to count the number of active contacts within a company.

A partner in the AW zone had an extremely high number of active contacts associated with a single account (>150,000). When resources at that partner began using the new Company user experience, this inefficient method overwhelmed the web tier and caused the process to run out of memory.

Our Development and Infrastructure teams began gathering data and mitigating the impact immediately. The edge-case was identified and a hotpatch to address the inefficient active contact count was deployed early the following morning (Thursday June 24)

Posted Jun 29, 2021 - 17:39 UTC

Resolved
This incident has been resolved.
Posted Jun 29, 2021 - 17:38 UTC
Monitoring
The issue affecting our AW Zone (ww5) has been resolved. We are continuing to monitor the results.

Thank you for time and patience.
Posted Jun 23, 2021 - 18:17 UTC
Investigating
Our teams are currently investigating Service unavailable or long loading times for PSA in our AW Zone (ww5).
Updates will be posted here with the status of this investigation.

Thank you for your patience!
Posted Jun 23, 2021 - 17:44 UTC
This incident affected: Autotask PSA (America West).