Datto Partner Portal Timeout Errors
Incident Report for Datto
Postmortem

On 11/15/2022 at 17:30 UTC, on-prem and Cloud Continuity partners experienced a service interruption while navigating the partner portal including errors while displaying the Recovery Launchpad and the Cloud Continuity Status page. 

The root cause for this service interruption was identified to be a new cloud-API release with changes that denied access to the read-only database in production. The cloud-API release was rolled back to its previous version on 11/15/2022 at 19:37 UTC and that mitigated the issue and service was restored back to normal. The engineering team has since fixed the configuration and introduced a health check to ensure connections have the required access to databases upon new releases.

Posted Nov 28, 2022 - 17:28 UTC

Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 21:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 15, 2022 - 19:39 UTC
Investigating
We are currently aware of a problem where Partner Portal users can experience a timeout error when attempting to navigate the Partner Portal.

Our Engineering team is actively investigating this issue.

Currently, we do not have an ETA on when a fix will be available.

You can monitor the current status of this issue at https://status.datto.com/
Posted Nov 15, 2022 - 18:18 UTC
This incident affected: Partner Portal.