Endpoint Backup - Agent Registrations failing for deployments in the US region
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jul 01, 2024 - 13:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 27, 2024 - 15:03 UTC
Investigating
We are aware of a problem where Endpoint Backup agent registrations may fail for deployments in the US region.

The Kaseya R&D Team has identified the problem and is working on a resolution.
Posted Jun 27, 2024 - 13:01 UTC
This incident affected: Endpoint Backup (Agent Registration).