PSA - LON Zone (WW4 - LON) - Service unavailable or long loading time - Under Investigation
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Apr 28, 2021 - 09:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2021 - 09:05 UTC
Investigating
Our teams are currently investigating Service unavailable or long loading times for PSA on LON Zones. Updates will be posted here as we progress with the status of this investigation.

Thank you for your patience!
Posted Apr 28, 2021 - 08:39 UTC
This incident affected: Autotask PSA (UK (United Kingdom)).