RMM - Concord - Issues with connecting to devices via the Agent Browser
Incident Report for Datto
Postmortem

On November 22, 2022 14:50 UTC, RMM partners on the Concord platform experienced issues connecting to devices via the Agent Browser. The connection was slow to establish and users might have been prompted to enter their credentials in the Agent Browser. The connection events failed to be logged in the Legacy UI.

The root cause for this incident was that the service responsible for indexing the related activity log entries in the legacy UI entered a bad state. The initial step when establishing the connection is that the event is indexed and logged in the Legacy UI: the indexing had to time out before the connection could establish during the incident. This led to the delay that users experienced.

The service instances were restarted to return them to a healthy state and resolve the incident. The service was determined to be fully operational on November 22, 18:17 UTC.

As a result of this issue, some connection events were not logged in the Legacy UI, however, the corresponding New UI Activity Log entries were uneffected.

As part of the transition to the New UI and the end-of-life of the Legacy UI, this backgroud step will be removed from the connection process.

Posted Feb 23, 2023 - 10:31 UTC

Resolved
A fix has been deployed, connecting to devices via the Agent Browser is now fully functional in the Legacy UI.

The User Activity page in the Legacy UI could be impacted as a result of this incident, more information will be communicated in the RCA. The New UI Unified Activity Log continues to be available and fully functional.
Posted Nov 23, 2022 - 08:48 UTC
Identified
The issue has been identified and we are working on a fix.

The User Activity page in the Legacy UI might display an error while we are working on the fix. The New UI Unified Activity Log continues to be available and fully functional.
Posted Nov 22, 2022 - 18:11 UTC
Update
Our teams are currently investigating reports of issues with connecting to devices via the Agent Browser on the Concord platform.

We will provide updates as they become available, thank you for your patience!
Posted Nov 22, 2022 - 16:24 UTC
Investigating
Our teams are currently investigating reports of issues with connecting to devices via the Agent Browser on the Concord platform.

We will provide updates as they become available, thank you for your patience!
Posted Nov 22, 2022 - 15:09 UTC
This incident affected: Datto RMM (Concord (US East)).