RMM/PSA SSO Users are unable to login- All Platforms
Incident Report for Datto
Postmortem

On September 14, 2022 at 06:39 UTC, RMM Partners started experiencing a service interruption which caused login failures via PSA.

The root cause for this service interruption was identified to be a change intended to support a new Autotask PSA SSO certificate.

While this is routinely done successfully, at this time, due to defect introduced in a previous version of Datto RMM, the SSO flow from PSA to RMM started to fail when support for the new certificate was added.

Our Engineering team reverted the change on September 14, 2022 at 16:54 UTC and deployed a fix to correct the defect causing the issue.

After this fix the support for the new certificate was reintroduced and the issue was considered resolved.

When the changeover to the new certificate was due on a specific Autotask Database Zone, it became apparent that the certificate has not been applied by the automation in place. This caused the same issue to reoccur on September 27, 2022 localised to the ww14 zone of Autotask PSA. This has been resolved by manually changing over to the new certificate.

Posted Oct 26, 2022 - 09:57 UTC

Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 16:50 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2022 - 14:43 UTC
Investigating
Our teams are currently investigating the issues where RMM/PSA SSO users are unable to login, this is affecting all platforms.

Users encountering the error should reset their credentials and log in to RMM through auth.datto.com.

Thank you for your patience!
Posted Sep 14, 2022 - 13:51 UTC
This incident affected: Datto RMM (Pinotage (EU1), Merlot (EU2), Zinfandel (US West), Concord (US East), Syrah (APAC), Vidal (US East)) and Partner Portal.