Agent connectivity issues, false offline alerts - Concord platform
Incident Report for Datto
Postmortem

User Impact:

Devices reconnecting and general connection instability, causing dropped sessions and false offline alerts.

Root Cause Analysis:

Duplicated job deployment records caused increased processing times for Ping Commands, delaying responses and causing devices to be marked offline.We are implementing schema changes with the 7.2.0 release to prevent further duplicates from occurring.

Kind Regards,
Datto, Inc.

Posted 3 months ago. Jun 07, 2019 - 13:46 UTC

Resolved
Full platform functionality has been restored.
Posted 3 months ago. Jun 06, 2019 - 16:50 UTC
Identified
We have identified the issue and are working to resume normal operation. Thank you for your continued patience.
Posted 3 months ago. Jun 06, 2019 - 16:41 UTC
Update
We are continuing to investigate this behavior and determine the root cause. We will update this post 30 minutes from now. We thank you for your continued patience.
Posted 3 months ago. Jun 06, 2019 - 16:17 UTC
Investigating
We are currently investigating a number of reports of agents going offline / false offline alerts being generated on the Concord platform. We will update this page within 30 minutes with an update as to the status. Thank you for your patience!
Posted 3 months ago. Jun 06, 2019 - 15:47 UTC
This incident affected: Datto RMM (Concord (US East)).