PSA - Reports of Latency (EU1)
Incident Report for Datto
Postmortem

On Tuesday, May 12th, starting at 14:38 UTC, Partners in the EU1 zone started to experience increased latency when navigating within their PSA database. Internal investigations showed no errors in our PSA data center infrastructure, and the error strings reported indicated an issue with our Content Delivery Network provider. We forced a cache refresh at the CDN provider’s edge servers which restored normal operations to affected partners. Investigation into our CDN provider’s edge servers yielded no immediate results, however their investigation is ongoing.

Posted May 22, 2020 - 17:10 UTC

Resolved
On Tuesday, May 12th, starting at 14:38 UTC, Partners in the EU1 zone started to experience increased latency when navigating within their PSA database. Internal investigations showed no errors in our PSA data center infrastructure, and the error strings reported indicated an issue with our Content Delivery Network provider. We forced a cache refresh at the CDN provider’s edge servers which restored normal operations to affected partners. Investigation into our CDN provider’s edge servers yielded no immediate results, however their investigation is ongoing.
Posted May 12, 2020 - 14:35 UTC