PSA - UK2 & LON Zones- Email OTP unavailable - Under Investigation
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 12:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 22, 2021 - 11:45 UTC
Investigating
Our teams are currently investigating Email OTP delays for PSA on LON Zones. An update will be posted here with the progress of this investigation.

Thank you for your patience!
Posted Feb 22, 2021 - 10:46 UTC
This incident affected: Autotask PSA (UK (United Kingdom), UK 2 (United Kingdom)).