PSA - AE2 - Reports of long load time/unresponsive pages
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Feb 01, 2023 - 20:11 UTC
Monitoring
A fix has been implemented and we are monitoring results.
Posted Feb 01, 2023 - 17:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 01, 2023 - 17:01 UTC
Investigating
Our teams are currently investigating reports of long load times/unresponsive pages for PSA on the AE2 Zone.

Thank you for your patience!
Posted Feb 01, 2023 - 15:51 UTC
This incident affected: Autotask PSA (America East 2).