Concord: Agent Browser based remote connection isn't working
Incident Report for Datto
Resolved
The issue with remote control via agent browser on the Concord platform is now confirmed resolved.

We genuinely appreciate your patience and apologies for any inconvenience this may have caused.
Posted May 13, 2020 - 00:25 UTC
Monitoring
This issue has now been resolved, however our engineers are continuing to monitor and we will update this status within the hour.

Thank you for your patience.
Posted May 12, 2020 - 23:07 UTC
Investigating
We have received reports of remote control not working via agent browser on our Concord platform.
We are currently investigating this issue.
As a workaround please use web remote while we get this resolved.
Thank you for your patience and understanding.
Posted May 12, 2020 - 22:17 UTC
This incident affected: Datto RMM (Concord (US East)).