PSA - LON Zone (WW16) - Latency and CLEP delays - Under Investigation
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 13:14 UTC
Monitoring
A fix has been implemented and emails should be processed normally.
Posted Jan 04, 2021 - 12:35 UTC
Investigating
Our teams are currently investigating latency and CLEP delays for PSA on the UK2 / WW16 Zone. An update will be posted here with the status of this investigation.

Thank you for your patience!
Posted Jan 04, 2021 - 12:09 UTC
This incident affected: Autotask PSA (UK 2 (United Kingdom)).