Salesforce Outage Impacting Datto Support
Incident Report for Datto
Resolved
Following Salesforce's return to service, our engineers have confirmed Partners are able to access help.datto.com and our ticketing and phone systems are functioning as expected.

We apologise for any inconvenience caused.
Posted May 12, 2021 - 01:22 UTC
Monitoring
Salesforce have identified the cause of their outage and are in the process of bringing impacted services back online.

Impacted Datto services (Help.datto.com and our internal ticketing and phone systems) are returning to service in light of the above. Our engineers are actively monitoring to ensure a full restoration of service and we will update this status once confirmed.

Thank you for your patience.
Posted May 12, 2021 - 00:33 UTC
Update
The Salesforce outage continues to impact our Partner's ability to log into help.datto.com as well as Datto Support's internal ticketing and phone systems.

We are actively monitoring the Salesforce outage and will provide further updates as soon as they are available.
Posted May 11, 2021 - 23:10 UTC
Identified
We are aware of the Salesforce outage which is currently impacting Partner's ability to log into help.datto.com as well as Datto Support's internal ticketing and phone systems.

We are currently monitoring the Salesforce outage and will provide an update once services have been restored.
Posted May 11, 2021 - 22:04 UTC
This incident affected: Datto Login Services and Datto Phones (Support Phones).