SaaS Protection and Backupify Console Login Issues
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jan 07, 2020 - 19:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results. We are expecting full resolution in the next hour.
Posted Jan 07, 2020 - 18:33 UTC
Investigating
We are aware of some ongoing issues logging into the Backupify/SaaS Protection Application. We are currently investigating and will provide more information soon.
Posted Jan 07, 2020 - 17:50 UTC
This incident affected: Datto SaaS Protection and Backupify (Backupify SaaS Console Login).