RMM - Concord - Delays with audit processing
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jun 23, 2022 - 22:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2022 - 21:48 UTC
Identified
Our teams are aware, and working on resolving the current delays in audit processing on the Concord platform

Thank you for your patience, and we apologize for the inconvenience!
Posted Jun 23, 2022 - 15:23 UTC
This incident affected: Datto RMM (Concord (US East)).