Datto SaaS Protection - Degraded M365 Teams Backups On V3 Platform
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jun 26, 2024 - 17:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2024 - 13:25 UTC
Identified
We are currently aware of a problem where a subset of M365 Teams services can experience a backup error on the V3 platform due to Microsoft API throttling.


The Kaseya R&D Team has identified the issue and is working towards a resolution.


Subscribe to Datto SaaS Protection on the Status Page for up to date information :


https://status.datto.com/
Posted Jun 17, 2024 - 13:54 UTC
This incident affected: Datto SaaS Protection (SaaS Protection Backups).