PSA - Email Processing Delays - AE and AW2
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 18:07 UTC
Monitoring
We have identified and corrected an issue that has resulted in the delay of email processing. We are monitoring the results update this space accordingly.
Posted Jul 28, 2020 - 15:37 UTC
This incident affected: Autotask PSA (America East, America West 2).