Partner Portal and Authentication Outage including Backupify, PSA and RMM
Incident Report for Datto
Resolved
Services continue to be stable and our engineers confirm the root cause has been successfully remediated.

This incident is now resolved.

We thank you for your patience and apologize for any inconvenience caused.
Posted Sep 04, 2020 - 03:58 UTC
Update
All services remain stable. Our engineers are continuing to monitor the issue and we will provide further updates within the next 4 hours.

We appreciate your continued patience.
Posted Sep 04, 2020 - 02:32 UTC
Monitoring
Our engineers have identified and resolved the issue. Services have been restored and we are continuing to monitor.

We appreciate your patience and will update this status within 2 hours.
Posted Sep 03, 2020 - 23:52 UTC
Investigating
We are currently investigating an issue with accessing the Datto Partner Portal and authentication when logging into other Datto services (Backupify, PSA, RMM). Partners may encounter an internal server error when accessing these services.

We apologize for the inconvenience and will update this page within 30 minutes.
Posted Sep 03, 2020 - 23:20 UTC
This incident affected: Datto Login Services and Partner Portal.