Backupify SaaS Console Login Outage
Incident Report for Datto
Postmortem

This outage impacted only a subset of SaaS Protection customers, and was caused as an unanticipated side-effect of planned systems maintenance on one of the servers related to authentication. The maintenance work was halted and all changes rolled back. We apologize for any inconvenience the partial interruption may have caused.

Posted 9 days ago. Mar 17, 2019 - 00:52 UTC

Resolved
Our engineering team has been closely monitoring this problem. The service has been deemed stable. We are now marking this incident as resolved. If you are still experiencing difficulties, please reach out to our Support Team at 877-455-6015. A post-mortem is forthcoming. Thank you for your patience.
Posted 14 days ago. Mar 11, 2019 - 17:54 UTC
Investigating
We are currently experiencing a disruption in the Backupify SaaS Console. We apologize for any inconvenience. We are investigating the root-cause of the problem and will be updating regularly. Please subscribe to receive these regular updates.
Posted 14 days ago. Mar 11, 2019 - 17:07 UTC
This incident affected: Backupify SaaS Console Login.