Application Support unavailable
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Feb 18, 2020 - 11:55 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2020 - 09:42 UTC
Investigating
Dear Partners,

Our offices are currently experiencing a technical fault with our internet connectivity. Unfortunately, We only have a few remote technical representatives available at the present time. If your issue is urgent please contact us on chat, for all other queries please send us an email.

We apologise for the inconvenience.
Posted Feb 18, 2020 - 09:03 UTC
This incident affected: Autotask PSA (UK Limited Release (United Kingdom), UK (United Kingdom), UK 2 (United Kingdom), EU1 (English Europe and Asia)).