PSA - EU1 Zone (WW19) - Long loading time - Under Investigation
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Oct 05, 2021 - 08:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 04, 2021 - 09:03 UTC
Investigating
Our teams are currently investigating long loading times for PSA on the EU1 Zone. An update will be posted here as we progress with this investigation.

Thank you for your patience!
Posted Oct 04, 2021 - 08:29 UTC
This incident affected: Autotask PSA (EU1 (English Europe and Asia)).