Datto SaaS Defense - Onboarding Outage
Incident Report for Datto
Postmortem

On 5/17/2022 at 12:30pmEST, SaaS Defense Partners experienced a service interruption which caused some resellers inability to onboard new clients to SaaS Defense in the US region.

The root cause for this service interruption was identified to be a package that was updated and broke a certain function in the code, that is being used during onboarding,  and was deployed to production as part of a new feature that was deployed to help us better handle scale regarding office365 users.

Our Engineering team deployed a fix to correct the problem on 5/17/2022 at 2:00pmEST

While this was tested in staging, the specific scenario was not covered. This and other scenarios have been added to future testing development.

Posted May 20, 2022 - 17:36 UTC

Resolved
SaaS Defense Partners experienced a service interruption which caused some resellers inability to onboard new clients to SaaS Defense in the US region.
Posted May 17, 2022 - 16:30 UTC