RMM - Pinotage - Devices Appearing Offline
Incident Report for Datto
Postmortem

On September 17th, 2021 - 10:35 UTC, RMM Partners on the Pinotage platform experienced a service interruption which caused devices to display as offline.

The root cause for this service interruption was caused by Control Channel handshake errors, which were generated by long running database transactions

Our Engineering team took action to resolve the issue by September 17th, 2021 - 11:45 UTC

We are introducing code in the 9.9.0 release that will attempt to automatically resolve long running transactions to prevent this issue from surfacing in the future.

Posted Sep 17, 2021 - 14:09 UTC

Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 14:04 UTC
Monitoring
Our Teams have received reports of devices appearing offline on the Pinotage platform.

Engineering has taken steps to resolve the issue, and devices should continue coming back online. We are monitoring the health of device connections.

We apologise for this experience and appreciate your patience!
Posted Sep 17, 2021 - 11:41 UTC
This incident affected: Datto RMM (Pinotage (EU1)).